summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-02-02 15:17:23 +0100
committerAlex Auvolat <alex@adnab.me>2023-02-02 15:17:23 +0100
commit552fc7e5a0d623114901d4d8e8e29bfffa47e09c (patch)
tree324903c281474e15aea8e9d86b600c6ecb3999f0 /Cargo.toml
parent19220178311ca80374f6f5ff4069c0adcaab932d (diff)
downloaddf-consul-552fc7e5a0d623114901d4d8e8e29bfffa47e09c.tar.gz
df-consul-552fc7e5a0d623114901d4d8e8e29bfffa47e09c.zip
Split into several files and make more APIs
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a36f28b..b5860aa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,6 +15,8 @@ serde = { version = "1.0.149", features = ["derive"] }
log = "0.4"
bytes = "1"
reqwest = { version = "0.11", default-features = false, features = ["json", "rustls-tls-manual-roots" ] }
+tokio = { version = "1.23", default-features = false, features = [ "macros" ] }
+futures = "0.3.25"
[dev-dependencies]
-tokio = { version = "1.22", features = ["rt", "rt-multi-thread", "macros"] }
+tokio = { version = "1.23", features = ["rt", "rt-multi-thread", "macros"] }