summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-01-05 11:27:18 +0100
committerAlex Auvolat <alex@adnab.me>2023-01-05 11:27:18 +0100
commit19220178311ca80374f6f5ff4069c0adcaab932d (patch)
tree0c93f733cda141a39474f79b69d4658523cf5278 /Cargo.toml
parentb0af49c24c0f8e006e02704d398318cf74ae1d6f (diff)
downloaddf-consul-19220178311ca80374f6f5ff4069c0adcaab932d.tar.gz
df-consul-19220178311ca80374f6f5ff4069c0adcaab932d.zip
Properly handle empty node catalog
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 06c2143..a36f28b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,7 @@
name = "df-consul"
description = "Deuxfleurs' async Rust bindings for (a subset of) the Consul HTTP API"
authors = [ "Alex Auvolat <alex@adnab.me>" ]
-version = "0.1.0"
+version = "0.2.0"
edition = "2021"
license = "MIT"
repository = "https://git.deuxfleurs.fr/Deuxfleurs/df-consul"
@@ -15,3 +15,6 @@ serde = { version = "1.0.149", features = ["derive"] }
log = "0.4"
bytes = "1"
reqwest = { version = "0.11", default-features = false, features = ["json", "rustls-tls-manual-roots" ] }
+
+[dev-dependencies]
+tokio = { version = "1.22", features = ["rt", "rt-multi-thread", "macros"] }