aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-12-05 18:43:48 +0100
committerAlex Auvolat <alex@adnab.me>2022-12-05 18:43:48 +0100
commit5d38f2cf7f312de69a3106556fc43219ca1473c3 (patch)
tree2ecc767ffeae5dd9b4a528f8294a61385a1fb5b1 /Cargo.toml
parent43a0fe14b2ae6a3e97f39169cda7ca5579a3259c (diff)
downloadtricot-5d38f2cf7f312de69a3106556fc43219ca1473c3.tar.gz
tricot-5d38f2cf7f312de69a3106556fc43219ca1473c3.zip
Add basic support for metrics
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a41b3c3..416038f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,6 +34,9 @@ accept-encoding-fork = "0.2.0-alpha.3"
async-compression = { version = "0.3", features = ["tokio", "gzip", "zstd", "deflate", "brotli"] }
tokio-util = { version = "0.7", features = ["io"] }
uuid = { version = "1.2", features = ["v4"] }
+opentelemetry = "0.17"
+opentelemetry-prometheus = "0.10"
+prometheus = "0.13"
dhat = { version = "0.3", optional = true }