aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-12-05 17:45:21 +0100
committerAlex Auvolat <alex@adnab.me>2022-12-05 17:52:27 +0100
commit43a0fe14b2ae6a3e97f39169cda7ca5579a3259c (patch)
tree30589d3e2b8b5e55520af303304c5bef6c4b5cf2 /Cargo.toml
parentd523c27ae4b3d86eb67fcf85af23ad223fd09b6c (diff)
downloadtricot-43a0fe14b2ae6a3e97f39169cda7ca5579a3259c.tar.gz
tricot-43a0fe14b2ae6a3e97f39169cda7ca5579a3259c.zip
Update dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index dd91560..a41b3c3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,34 +7,34 @@ authors = ["Alex Auvolat <alex@adnab.me>"]
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-anyhow = "1.0.28"
+anyhow = "1.0.66"
envy = "0.4"
futures = "0.3"
log = "0.4"
pretty_env_logger = "0.4"
regex = "1"
reqwest = { version = "0.11", default-features = false, features = ["json", "rustls-tls-manual-roots" ] }
-serde = { version = "1.0.107", features = ["derive"] }
-serde_json = "1.0.53"
-tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
+serde = { version = "1.0.149", features = ["derive"] }
+serde_json = "1.0.89"
+tokio = { version = "1.22", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
bytes = "1"
acme-micro = "0.12"
rustls = { version = "0.20", features = [ "dangerous_configuration" ] }
-rustls-pemfile = "0.2"
+rustls-pemfile = "1.0"
chrono = { version = "0.4", features = [ "serde" ] }
hyper = { version = "0.14", features = [ "full" ] }
futures-util = "0.3"
tokio-rustls = "0.23"
hyper-rustls = "0.23"
http = "0.2"
-hyper-reverse-proxy = "0.4"
structopt = "0.3"
glob = "0.3"
-rcgen = "0.8"
+rcgen = "0.10"
accept-encoding-fork = "0.2.0-alpha.3"
async-compression = { version = "0.3", features = ["tokio", "gzip", "zstd", "deflate", "brotli"] }
-tokio-util = { version = "0.6", features = ["io"] }
-uuid = { version = "0.8.2", features = ["v4"] }
+tokio-util = { version = "0.7", features = ["io"] }
+uuid = { version = "1.2", features = ["v4"] }
+
dhat = { version = "0.3", optional = true }
[profile.release]