aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..fefedc9
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,20 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "node";
+ buildInputs = [
+ nodejs
+ zola
+ ];
+ shellHook = ''
+ export PATH="$PWD/node_modules/.bin/:$PATH"
+ function build {
+ rm -r content/documentation static/api
+ cp -rv garage/doc/book content/documentation
+ cp -rv garage/doc/api static/api
+ npm install
+ npx tailwindcss -i ./src/input.css -o ./static/style.css --minify
+ zola build -u https://garagehq.deuxfleurs.fr
+ }
+ '';
+}