aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-11-16 12:06:57 +0100
committerAlex Auvolat <alex@adnab.me>2022-11-16 12:06:57 +0100
commit1559433753adedd2de5695c0892a6e1df25cf304 (patch)
tree55d092efd0a3acb9253f09788178f8351a5adfcd /shell.nix
parent08d43d3a9553dffc7f7ea916ef3890b7208c5aec (diff)
downloadgaragehq.deuxfleurs.fr-1559433753adedd2de5695c0892a6e1df25cf304.tar.gz
garagehq.deuxfleurs.fr-1559433753adedd2de5695c0892a6e1df25cf304.zip
Add shell.nix and update garage source, include api docs copy
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..fefedc9
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,20 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "node";
+ buildInputs = [
+ nodejs
+ zola
+ ];
+ shellHook = ''
+ export PATH="$PWD/node_modules/.bin/:$PATH"
+ function build {
+ rm -r content/documentation static/api
+ cp -rv garage/doc/book content/documentation
+ cp -rv garage/doc/api static/api
+ npm install
+ npx tailwindcss -i ./src/input.css -o ./static/style.css --minify
+ zola build -u https://garagehq.deuxfleurs.fr
+ }
+ '';
+}