aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-10-10 13:56:33 +0200
committerAlex Auvolat <alex@adnab.me>2023-10-10 13:56:48 +0200
commitd3fffd30dcf66a9da2e466ae6274547b090313e2 (patch)
tree5d6a025d99823dc9810e0b2876c1566fdf970343 /flake.nix
parente75fe2157d0973eb4320bbc87be5e54a1cb91a63 (diff)
downloadgarage-d3fffd30dcf66a9da2e466ae6274547b090313e2.tar.gz
garage-d3fffd30dcf66a9da2e466ae6274547b090313e2.zip
use mold linker when invoking cargo manually (not in nix build scripts)mold-linker
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 32c01616..f8d7d4df 100644
--- a/flake.nix
+++ b/flake.nix
@@ -48,6 +48,9 @@
pkgsSrc = nixpkgs;
cargo2nixOverlay = cargo2nix.overlays.default;
release = false;
- }).workspaceShell { packages = [ pkgs.rustfmt ]; };
+ }).workspaceShell { packages = with pkgs; [
+ rustfmt
+ mold
+ ]; };
});
}