aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2024-03-08 08:17:03 +0100
committerQuentin Dufour <quentin@deuxfleurs.fr>2024-03-08 08:17:03 +0100
commit1a43ce5ac7033c148f64a033f2b1d335e95e11d5 (patch)
tree60b234604170fe207248458a9c4cdd3f4b7c36f2 /Cargo.toml
parentbb9cb386b65834c44cae86bd100f800883022062 (diff)
downloadaerogramme-1a43ce5ac7033c148f64a033f2b1d335e95e11d5.tar.gz
aerogramme-1a43ce5ac7033c148f64a033f2b1d335e95e11d5.zip
WIP refactor
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml41
1 files changed, 23 insertions, 18 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 543b463..56d5cf3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,16 +1,28 @@
-[package]
-name = "aerogramme"
-version = "0.3.0"
-authors = ["Alex Auvolat <alex@adnab.me>", "Quentin Dufour <quentin@dufour.io>"]
-edition = "2021"
-license = "EUPL-1.2"
-description = "A robust email server"
+[workspace]
+resolver = "2"
+members = [
+ "aero-user",
+ "aero-bayou",
+ "aero-sasl",
+ "aero-dav",
+ "aero-dav/fuzz",
+# "aero-collections",
+# "aero-proto",
+# "aerogramme",
+]
-[lib]
-name = "aerogramme"
-path = "src/lib.rs"
+default-members = ["aerogramme"]
+
+[workspace.dependencies]
+# internal crates
+aero-user = { version = "0.3.0", path = "aero-user" }
+aero-bayou = { version = "0.3.0", path = "aero-bayou" }
+aero-sasl = { version = "0.3.0", path = "aero-sasl" }
+aero-dav = { version = "0.3.0", path = "aero-dav" }
+#aero-collections = { version = "0.3.0", path = "aero-collections" }
+#aero-proto = { version = "0.3.0", path = "aero-proto" }
+#aerogramme = { version = "0.3.0", path = "aerogramme" }
-[dependencies]
# async runtime
tokio = { version = "1.18", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
tokio-util = { version = "0.7", features = [ "compat" ] }
@@ -80,13 +92,6 @@ aws-sdk-s3 = "1"
aws-smithy-runtime = "1"
aws-smithy-runtime-api = "1"
-[dev-dependencies]
-
[patch.crates-io]
imap-types = { git = "https://github.com/superboum/imap-codec", branch = "custom/aerogramme" }
imap-codec = { git = "https://github.com/superboum/imap-codec", branch = "custom/aerogramme" }
-
-[[test]]
-name = "behavior"
-path = "tests/behavior.rs"
-harness = false