summaryrefslogtreecommitdiff
path: root/nixos/wayfire.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/wayfire.nix')
-rw-r--r--nixos/wayfire.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/nixos/wayfire.nix b/nixos/wayfire.nix
index 10ae1f6..2feeefd 100644
--- a/nixos/wayfire.nix
+++ b/nixos/wayfire.nix
@@ -8,6 +8,21 @@
security.pam.services.swaylock = {};
+ programs.sway = {
+ enable = true;
+ #package = pkgs.swayfx;
+ wrapperFeatures.gtk = true;
+ wrapperFeatures.base = true;
+ extraPackages = with pkgs; [
+ glib
+ ];
+ };
+ qt = {
+ enable = true;
+ platformTheme = "gnome";
+ style = "adwaita";
+ };
+
environment.systemPackages = with pkgs; [
# ---- wayfire ----
#wayfire-with-plugins
@@ -15,7 +30,7 @@
#wayfirePlugins.wf-shell
# ---- sway ----
- swayfx
+ #swayfx
swaybg
bemenu
swayimg
@@ -26,5 +41,6 @@
alacritty
swaylock
wdisplays
+ grim
];
}