summaryrefslogtreecommitdiff
path: root/nixos/wayfire.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/wayfire.nix')
-rw-r--r--nixos/wayfire.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/nixos/wayfire.nix b/nixos/wayfire.nix
new file mode 100644
index 0000000..004ad43
--- /dev/null
+++ b/nixos/wayfire.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, modulesPath, ... }:
+{
+ imports = [
+ ./wmonly.nix
+ ];
+
+ services.xserver.displayManager.sx.enable = true;
+
+ security.pam.services.swaylock = {};
+
+ environment.systemPackages = with pkgs; [
+ wayfire-with-plugins
+ wayfirePlugins.wcm
+ wayfirePlugins.wf-shell
+ waybar
+ alacritty
+ swaylock
+ ];
+}