summaryrefslogtreecommitdiff
path: root/nixos/route48.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/route48.nix')
-rw-r--r--nixos/route48.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/nixos/route48.nix b/nixos/route48.nix
new file mode 100644
index 0000000..3dbdb44
--- /dev/null
+++ b/nixos/route48.nix
@@ -0,0 +1,13 @@
+{ config, pkgs, ... }:
+{
+ networking.wg-quick.interfaces.route48 = {
+ privateKeyFile = "/root/route48private";
+ address = [ "2a06:a004:3089::2/48" ];
+ peers = [{
+ publicKey = "W0pI832mL5u7JzJjiE68dyS95mIGBDqGgSxSZromEGY=";
+ allowedIPs = ["::/1" "8000::/1"];
+ endpoint = "par-fr.node.route48.org:51890";
+ persistentKeepalive = 60;
+ }];
+ };
+}