summaryrefslogtreecommitdiff
path: root/nixos/lindy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/lindy.nix')
-rw-r--r--nixos/lindy.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/nixos/lindy.nix b/nixos/lindy.nix
index bcc662e..d7672c9 100644
--- a/nixos/lindy.nix
+++ b/nixos/lindy.nix
@@ -21,7 +21,6 @@
boot.zfs.extraPools = [ "Zonz" ];
services.zfs.autoScrub.enable = true;
services.zfs.autoScrub.pools = [ "Zonz" ];
- environment.systemPackages = [ pkgs.zfs ];
# Use Grub
boot.loader.grub.enable = true;
@@ -83,6 +82,12 @@ Kogami UUID=61534c91-df18-4c71-9244-54e677f5d4fa /root/kogami_key
services.xserver.videoDrivers = [ "nvidia" ];
hardware.opengl.enable = true;
+ # Docker
+ virtualisation.docker.enable = true;
+ users.users.lx.extraGroups = [ "docker" ];
+
+ environment.systemPackages = with pkgs; [ zfs docker-compose ];
+
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
hardware.cpu.intel.updateMicrocode =