summaryrefslogtreecommitdiff
path: root/nixos/kusanagi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/kusanagi.nix')
-rw-r--r--nixos/kusanagi.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/nixos/kusanagi.nix b/nixos/kusanagi.nix
index 3cbbef3..4b75489 100644
--- a/nixos/kusanagi.nix
+++ b/nixos/kusanagi.nix
@@ -24,11 +24,16 @@
boot.kernelModules = [ "kvm-intel" ];
boot.extraModulePackages = [ ];
- # Old computer challenge
- boot.kernelParams = [
- "maxcpus=1"
- "mem=512M"
- ];
+ specialisation = {
+ # Old computer challenge
+ tiny.configuration = {
+ boot.kernelParams = [
+ "maxcpus=1"
+ "mem=512M"
+ ];
+ powerManagement.cpuFreqGovernor = "powersave";
+ };
+ };
boot.initrd.luks.devices = {
crypted = {
@@ -94,7 +99,7 @@
];
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+ #powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
hardware.cpu.intel.updateMicrocode =
lib.mkDefault config.hardware.enableRedistributableFirmware;
}