summaryrefslogtreecommitdiff
path: root/nixos/kusanagi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/kusanagi.nix')
-rw-r--r--nixos/kusanagi.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/kusanagi.nix b/nixos/kusanagi.nix
index 3a89519..c6c224f 100644
--- a/nixos/kusanagi.nix
+++ b/nixos/kusanagi.nix
@@ -68,7 +68,7 @@ in
fileSystems."/" = {
device = "none";
fsType = "tmpfs";
- options = [ "defaults" "size=4G" "mode=755" ];
+ options = [ "defaults" "size=8G" "mode=755" ];
};
fileSystems."/persist" =
@@ -98,7 +98,7 @@ in
users.mutableUsers = false;
users.users.lx.passwordFile = "/Z/lx/.password";
users.users.lx.uid = 1000;
- users.users.lx.extraGroups = [ "vboxusers" ];
+ users.users.lx.extraGroups = [ "vboxusers" "docker" ];
# ---- no persistent home, use home manager to set everything up ----
@@ -133,6 +133,7 @@ in
# ---- other
+ virtualisation.docker.enable = true;
virtualisation.virtualbox.host.enable = true;
# ----