summaryrefslogtreecommitdiff
path: root/nixos/kusanagi-old.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/kusanagi-old.nix')
-rw-r--r--nixos/kusanagi-old.nix105
1 files changed, 105 insertions, 0 deletions
diff --git a/nixos/kusanagi-old.nix b/nixos/kusanagi-old.nix
new file mode 100644
index 0000000..4b75489
--- /dev/null
+++ b/nixos/kusanagi-old.nix
@@ -0,0 +1,105 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports = [
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ./common.nix
+ #./kde.nix
+ ./icewm.nix
+ #./gnome.nix
+ ];
+
+ networking.hostName = "kusanagi";
+
+ # Use systemd-boot
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ boot.initrd.availableKernelModules =
+ [ "xhci_pci" "nvme" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ specialisation = {
+ # Old computer challenge
+ tiny.configuration = {
+ boot.kernelParams = [
+ "maxcpus=1"
+ "mem=512M"
+ ];
+ powerManagement.cpuFreqGovernor = "powersave";
+ };
+ };
+
+ boot.initrd.luks.devices = {
+ crypted = {
+ device = "/dev/disk/by-uuid/e3271725-effb-4b00-a5d4-8a7a64f55420";
+ allowDiscards = true;
+ };
+ };
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/2f606c6b-8009-4158-b367-2e0cf1a57ade";
+ fsType = "ext4";
+ options = [ "discard" ];
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/0143-7D54";
+ fsType = "vfat";
+ };
+
+ fileSystems."/home" = {
+ device = "/dev/disk/by-uuid/f955ce34-f25e-4abf-8732-bcf17465f78c";
+ fsType = "ext4";
+ options = [ "discard" ];
+ };
+
+ swapDevices =
+ [{ device = "/dev/disk/by-uuid/c78cfb77-75ee-4aae-9b24-b91f8eebb7c2"; }];
+
+ # Nix-serve for friends on local network
+ services.nix-serve = {
+ enable = true;
+ secretKeyFile = "/var/lib/nix-serve/cache-priv-key.pem";
+ };
+ services.nginx = {
+ enable = true;
+ recommendedProxySettings = true;
+ virtualHosts = {
+ "adnab.local" = {
+ locations."/".proxyPass = "http://${config.services.nix-serve.bindAddress}:${toString config.services.nix-serve.port}";
+ };
+ };
+ };
+ networking.extraHosts = ''
+ 127.0.0.1 adnab.local
+ '';
+
+ # Docker
+ virtualisation.docker.enable = true;
+ users.users.lx.extraGroups = [ "docker" ];
+ environment.systemPackages = with pkgs; [
+ docker-compose
+ ];
+
+ # Printer
+ services.printing.drivers = [ pkgs.cups-brother-hl1210w ];
+
+ networking.firewall.allowedTCPPorts = [
+ 80 # nginx
+ 57890 # troop
+ ];
+ networking.firewall.allowedUDPPorts = [
+ 57890 # troop
+ ];
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ #powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+ hardware.cpu.intel.updateMicrocode =
+ lib.mkDefault config.hardware.enableRedistributableFirmware;
+}