summaryrefslogtreecommitdiff
path: root/nixos/common2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/common2.nix')
-rw-r--r--nixos/common2.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/nixos/common2.nix b/nixos/common2.nix
new file mode 100644
index 0000000..4c82e19
--- /dev/null
+++ b/nixos/common2.nix
@@ -0,0 +1,39 @@
+# More stuff, slows down boot process
+# so not enabled by default on kusanagi
+
+{ config, pkgs, lib, ... }:
+
+{
+ # Input method for japanese
+ i18n.inputMethod.enabled = "fcitx5";
+ i18n.inputMethod.fcitx5.addons = [ pkgs.fcitx5-mozc ];
+
+ # ---- hardware support
+
+ # Enable CUPS to print documents.
+ services.printing.enable = true;
+
+ # Enable RTL-SDR
+ hardware.rtl-sdr.enable = true;
+
+ # ---- networking
+
+ # Enable tailscale
+ services.tailscale.enable = true;
+
+ # Enable Tor daemon
+ services.tor = {
+ enable = true;
+ client.enable = true;
+ };
+
+ # ---- virtualization
+
+ # Enable libvirt
+ virtualisation.libvirtd.enable = true;
+
+ # Enable docker
+ virtualisation.docker.enable = true;
+
+ users.users.lx.extraGroups = [ "docker" "libvirtd" ];
+}