summaryrefslogtreecommitdiff
path: root/nixos/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/common.nix')
-rw-r--r--nixos/common.nix159
1 files changed, 159 insertions, 0 deletions
diff --git a/nixos/common.nix b/nixos/common.nix
new file mode 100644
index 0000000..c736938
--- /dev/null
+++ b/nixos/common.nix
@@ -0,0 +1,159 @@
+{ config, pkgs, ... }:
+
+{
+ networking.networkmanager.enable = true;
+
+ time.timeZone = "Europe/Paris";
+
+ i18n.defaultLocale = "en_US.UTF-8";
+ i18n.extraLocaleSettings = {
+ LC_ADDRESS = "fr_FR.utf8";
+ LC_IDENTIFICATION = "fr_FR.utf8";
+ LC_MEASUREMENT = "fr_FR.utf8";
+ LC_MONETARY = "fr_FR.utf8";
+ LC_NAME = "fr_FR.utf8";
+ LC_NUMERIC = "fr_FR.utf8";
+ LC_PAPER = "fr_FR.utf8";
+ LC_TELEPHONE = "fr_FR.utf8";
+ LC_TIME = "fr_FR.utf8";
+ };
+
+ console = {
+ font = "sun12x22";
+ #keyMap = "fr";
+ useXkbConfig = true; # use xkbOptions in tty.
+ };
+
+ # Enable the X11 windowing system.
+ services.xserver.enable = true;
+
+ # Configure keymap in X11
+ services.xserver.layout = "fr";
+ services.xserver.xkbOptions = "caps:escape";
+
+ # Enable CUPS to print documents.
+ # services.printing.enable = true;
+
+ # Enable sound.
+ sound.enable = true;
+ hardware.pulseaudio.enable = false;
+ services.pipewire = {
+ enable = true;
+ alsa.enable = true;
+ alsa.support32Bit = true;
+ pulse.enable = true;
+ };
+
+ # Enable touchpad support (enabled default in most desktopManager).
+ services.xserver.libinput.enable = true;
+
+ # Define a user account. Don't forget to set a password with ‘passwd’.
+ users.users.lx = {
+ isNormalUser = true;
+ description = "Alex";
+ extraGroups =
+ [ "networkmanager" "wheel" "yggdrasil" ]; # Enable ‘sudo’ for the user.
+ };
+
+ nixpkgs.config.allowUnfree = true;
+ nix.gc.automatic = true;
+ nix.gc.options = "--delete-older-than 30d";
+ nix.settings.experimental-features = [ "nix-command" "flakes" ];
+
+ environment.systemPackages = with pkgs; [
+ home-manager
+
+ profont
+ symbola
+
+ vim
+ vimPlugins.vim-nix
+ vimPlugins.fzf-vim
+ vimPlugins.nerdtree
+ tmux
+ git
+ git-lfs
+ pass
+ openssl
+ htop
+ powertop
+ iotop
+ jnettop
+ socat
+ nethogs
+ speedtest-cli
+ ncdu
+ dfc
+ wget
+ gcc
+ gnumake
+ rclone
+ restic
+ borgbackup
+ nomad
+ consul
+ nixfmt
+
+ alacritty
+ firefox
+ qutebrowser
+ (tor-browser-bundle-bin.override { useHardenedMalloc = false; })
+ lagrange
+ thunderbird
+ keepassxc
+ vlc
+ mpv
+ spotify
+ jellyfin-media-player
+ nheko
+ ];
+
+ programs.vim.defaultEditor = true;
+
+ programs.steam = {
+ enable = true;
+ remotePlay.openFirewall =
+ true; # Open ports in the firewall for Steam Remote Play
+ dedicatedServer.openFirewall =
+ true; # Open ports in the firewall for Source Dedicated Server
+ };
+
+ # Some programs need SUID wrappers, can be configured further or are
+ # started in user sessions.
+ programs.mtr.enable = true;
+ programs.gnupg.agent = {
+ enable = true;
+ enableSSHSupport = true;
+ };
+
+ # List services that you want to enable:
+
+ # Enable the OpenSSH daemon.
+ # services.openssh.enable = true;
+
+ services.yggdrasil = {
+ enable = true;
+ persistentKeys = true;
+ settings = { Peers = [ "tls://37.187.118.206:53103" ]; };
+ };
+
+ # Open ports in the firewall.
+ # networking.firewall.allowedTCPPorts = [ ... ];
+ # networking.firewall.allowedUDPPorts = [ ... ];
+ # Or disable the firewall altogether.
+ # networking.firewall.enable = false;
+
+ # Copy the NixOS configuration file and link it from the resulting system
+ # (/run/current-system/configuration.nix). This is useful in case you
+ # accidentally delete configuration.nix.
+ system.copySystemConfiguration = true;
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "22.11"; # Did you read the comment?
+}
+