summaryrefslogtreecommitdiff
path: root/lindy/nixos/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lindy/nixos/hardware-configuration.nix')
-rw-r--r--lindy/nixos/hardware-configuration.nix61
1 files changed, 61 insertions, 0 deletions
diff --git a/lindy/nixos/hardware-configuration.nix b/lindy/nixos/hardware-configuration.nix
new file mode 100644
index 0000000..a834491
--- /dev/null
+++ b/lindy/nixos/hardware-configuration.nix
@@ -0,0 +1,61 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "usbhid" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
+ boot.kernelModules = [ "kvm-intel" "wl" ];
+ boot.extraModulePackages = [ config.boot.kernelPackages.broadcom_sta ];
+
+ boot.initrd.luks.devices = {
+ cryptssd = {
+ device = "/dev/disk/by-uuid/1b074a78-9116-420e-b872-7bf49ca10ce1";
+ allowDiscards = true;
+ };
+ };
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/2e64e6fc-ab7c-4620-b56b-faee641bd2a6";
+ fsType = "ext4";
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/disk/by-uuid/1ef4b6f4-975d-4e04-9d88-0640e83ed0b4";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/0728e7e5-8e21-44bd-9287-eb066d489a0e";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot/efi" =
+ { device = "/dev/disk/by-uuid/02D0-F1C6";
+ fsType = "vfat";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/5950785a-9793-4d04-b791-8f4dbc497ec3"; }
+ ];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.br-1ab2b811ce21.useDHCP = lib.mkDefault true;
+ # networking.interfaces.docker0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp3s0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.virbr0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.wlp6s0.useDHCP = lib.mkDefault true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}