summaryrefslogtreecommitdiff
path: root/foxdot/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'foxdot/shell.nix')
-rw-r--r--foxdot/shell.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/foxdot/shell.nix b/foxdot/shell.nix
new file mode 100644
index 0000000..32c95ee
--- /dev/null
+++ b/foxdot/shell.nix
@@ -0,0 +1,14 @@
+{ pkgs ? import <nixpkgs> {} }:
+let
+ pypkgs = p: with p; [
+ foxdot
+ tkinter
+ ];
+ py = pkgs.python3.withPackages pypkgs;
+in
+ pkgs.mkShell {
+ packages = with pkgs; [
+ py
+ supercollider
+ ];
+}