summaryrefslogtreecommitdiff
path: root/nixos/kusanagi.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-01-17 12:45:46 +0100
committerAlex Auvolat <alex@adnab.me>2023-01-17 12:45:46 +0100
commitd47dd5aa3882aea1a8eff4fb9faa4881274559dc (patch)
treeb438c8fb8953b84614c170a5278ae72ece90bb68 /nixos/kusanagi.nix
parenteaf6d5b07bcdd9a3eb9bfdac93566b7432e46c37 (diff)
downloaduser-config-d47dd5aa3882aea1a8eff4fb9faa4881274559dc.tar.gz
user-config-d47dd5aa3882aea1a8eff4fb9faa4881274559dc.zip
Unify things and rename things
Diffstat (limited to 'nixos/kusanagi.nix')
-rw-r--r--nixos/kusanagi.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/nixos/kusanagi.nix b/nixos/kusanagi.nix
new file mode 100644
index 0000000..eea3f9e
--- /dev/null
+++ b/nixos/kusanagi.nix
@@ -0,0 +1,56 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports = [
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ./common.nix
+ ./kde.nix
+ #./gnome.nix
+ ];
+
+ networking.hostName = "kusanagi";
+
+ # Use systemd-boot
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+ boot.plymouth.enable = true;
+
+ boot.initrd.availableKernelModules =
+ [ "xhci_pci" "nvme" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ boot.initrd.luks.devices = {
+ crypted = {
+ device = "/dev/disk/by-uuid/e3271725-effb-4b00-a5d4-8a7a64f55420";
+ allowDiscards = true;
+ };
+ };
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/2f606c6b-8009-4158-b367-2e0cf1a57ade";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/0143-7D54";
+ fsType = "vfat";
+ };
+
+ fileSystems."/home" = {
+ device = "/dev/disk/by-uuid/f955ce34-f25e-4abf-8732-bcf17465f78c";
+ fsType = "ext4";
+ };
+
+ swapDevices =
+ [{ device = "/dev/disk/by-uuid/c78cfb77-75ee-4aae-9b24-b91f8eebb7c2"; }];
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+ hardware.cpu.intel.updateMicrocode =
+ lib.mkDefault config.hardware.enableRedistributableFirmware;
+}