summaryrefslogtreecommitdiff
path: root/nixos/common.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-01-24 11:44:27 +0100
committerAlex Auvolat <alex@adnab.me>2023-01-24 11:44:27 +0100
commit9edcf0276c98f9d52e276303484699a131157866 (patch)
treeabce6f7e705fb29eb5dd16fb19edba6e04714b7c /nixos/common.nix
parent011e64f047d1cf0108779f3a1516e00478056276 (diff)
downloaduser-config-9edcf0276c98f9d52e276303484699a131157866.tar.gz
user-config-9edcf0276c98f9d52e276303484699a131157866.zip
marvelous keymap
Diffstat (limited to 'nixos/common.nix')
-rw-r--r--nixos/common.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/nixos/common.nix b/nixos/common.nix
index a967e7d..84b5a17 100644
--- a/nixos/common.nix
+++ b/nixos/common.nix
@@ -1,5 +1,11 @@
{ config, pkgs, ... }:
+let
+ compiledXkbLayout = pkgs.runCommand "keyboard-layout" {} ''
+ ${pkgs.xorg.xkbcomp}/bin/xkbcomp ${../xkb/symbols/custom-fr} $out
+ '';
+in
+
{
boot.supportedFilesystems = [ "ntfs" ];
boot.cleanTmpDir = true;
@@ -23,8 +29,7 @@
console = {
font = "sun12x22";
- #keyMap = "fr";
- useXkbConfig = true; # use xkbOptions in tty.
+ keyMap = "fr";
};
# Enable the X11 windowing system.
@@ -32,6 +37,7 @@
# Configure keymap in X11
services.xserver.layout = "fr";
+ services.xserver.displayManager.sessionCommands = "${pkgs.xorg.xkbcomp}/bin/xkbcomp ${compiledXkbLayout} $DISPLAY";
services.xserver.xkbOptions = "caps:escape";
# Enable CUPS to print documents.