summaryrefslogtreecommitdiff
path: root/nixos/95theme.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-05-17 15:04:49 +0200
committerAlex Auvolat <alex@adnab.me>2023-05-17 15:04:49 +0200
commit75bd40070995da7d2f97cb2251522c65ecd9dd9a (patch)
tree52bf490bfa8cbf943e07f344826f0654cb5caa64 /nixos/95theme.nix
parent3f75a9d3fead0a3b857a39ffdf68ecf5c7186581 (diff)
downloaduser-config-75bd40070995da7d2f97cb2251522c65ecd9dd9a.tar.gz
user-config-75bd40070995da7d2f97cb2251522c65ecd9dd9a.zip
funky stuff
Diffstat (limited to 'nixos/95theme.nix')
-rw-r--r--nixos/95theme.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/nixos/95theme.nix b/nixos/95theme.nix
new file mode 100644
index 0000000..c17e336
--- /dev/null
+++ b/nixos/95theme.nix
@@ -0,0 +1,46 @@
+{ config, lib, pkgs, modulesPath, ... }:
+let chicago95 =
+ pkgs.stdenv.mkDerivation rec {
+ pname = "chicago95";
+ version = "20230216";
+
+ src = pkgs.fetchgit {
+ url = "https://github.com/grassmunk/Chicago95.git";
+ rev = "4c39951284add04941adc6ce5a68a778590b93d1";
+ hash = "sha256-PwNuVAcJ6FZlALdHAvgX8H56bOkZ0llXGd09ETj4enQ=";
+ };
+
+ nativeBuildInputs = with pkgs; [
+ which
+ ];
+
+ installPhase = ''
+ pwd
+ ls -lah
+ for p in cursors fonts gtk_theme icons backgrounds doc; do
+ make install_$p DESTDIR=$out prefix=
+ done
+ '';
+
+ meta = with lib; {
+ description = "A rendition of everyone's favorite 1995 Microsoft operating system for Linux";
+ homepage = "https://github.com/grassmunk/Chicago95";
+ platforms = platforms.all;
+ };
+ };
+in
+{
+ services.xserver.windowManager.icewm.enable = true;
+ services.xserver.windowManager.windowmaker.enable = true;
+ services.xserver.desktopManager.xfce.enable = true;
+
+ environment.systemPackages = with pkgs; [
+ # theming
+ onestepback
+ feh
+ lxappearance
+ chicago95
+ libsForQt5.qtstyleplugins
+ libsForQt5.qt5ct
+ ];
+}