summaryrefslogtreecommitdiff
path: root/kusanagi/nixos/hardware-configuration.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-12-30 15:27:24 +0100
committerAlex Auvolat <alex@adnab.me>2022-12-30 15:27:24 +0100
commit09ee5143b4d13ed0ca70d4904a9c2c5a058fcf9e (patch)
tree342f3380c364de521f462a20d28510bcf1ee5468 /kusanagi/nixos/hardware-configuration.nix
parentdf542cba83cc2ced2cc548de52b2f04a42bb47bb (diff)
downloaduser-config-09ee5143b4d13ed0ca70d4904a9c2c5a058fcf9e.tar.gz
user-config-09ee5143b4d13ed0ca70d4904a9c2c5a058fcf9e.zip
kusanagi on nixos config
Diffstat (limited to 'kusanagi/nixos/hardware-configuration.nix')
-rw-r--r--kusanagi/nixos/hardware-configuration.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/kusanagi/nixos/hardware-configuration.nix b/kusanagi/nixos/hardware-configuration.nix
new file mode 100644
index 0000000..e4827aa
--- /dev/null
+++ b/kusanagi/nixos/hardware-configuration.nix
@@ -0,0 +1,42 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ boot.initrd.luks.devices.crypted.device = "/dev/disk/by-uuid/e3271725-effb-4b00-a5d4-8a7a64f55420";
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/2f606c6b-8009-4158-b367-2e0cf1a57ade";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/0143-7D54";
+ fsType = "vfat";
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/disk/by-uuid/f955ce34-f25e-4abf-8732-bcf17465f78c";
+ fsType = "ext4";
+ };
+
+ swapDevices = [
+ {
+ device = "/dev/disk/by-uuid/c78cfb77-75ee-4aae-9b24-b91f8eebb7c2";
+ }
+ ];
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}