aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index f6b2973..973162e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,13 +3,14 @@
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-23.11";
};
- outputs = { self, nixpkgs } : {
- pkgs = import nixpkgs { system = "x86_64-linux"; };
- defaultPackage.x86_64-linux = pkgs.stdenv.rustPlatform.buildRustPackage rec {
+ outputs = { self, nixpkgs } :
+ let pkgs = import nixpkgs { system = "x86_64-linux"; };
+ in{
+ defaultPackage.x86_64-linux = pkgs.rustPlatform.buildRustPackage rec {
pname = "datagengo";
version = "0.0.1";
src = ./.;
-
+ cargoLock.lockFile = ./Cargo.lock;
};
};
}