aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-03-09 14:23:40 +0100
committerAlex Auvolat <alex@adnab.me>2023-03-09 14:23:40 +0100
commit52926d6152686ccf864fe281c03482b62fb6a749 (patch)
treeba60cb639554dc3d002b99b39bf61c80ab128d33 /Cargo.toml
parent7c9839f900171d88a4fd4cb6d7c5dc556817aace (diff)
downloadwgautomesh-52926d6152686ccf864fe281c03482b62fb6a749.tar.gz
wgautomesh-52926d6152686ccf864fe281c03482b62fb6a749.zip
gossip encryption (fix #4)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f722bf3..7a04067 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,8 @@ pretty_env_logger = "0.4.0"
serde = { version = "1.0", features = ["derive"] }
bincode = "1.3"
toml = { version = "0.7", default-features = false, features = ["parse"] }
+xsalsa20poly1305 = "0.9"
+blake3 = "1.3"
igd = { version = "0.12", default-features = false }
get_if_addrs = "0.5"