aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-10-02 13:28:40 +0200
committerAlex Auvolat <alex@adnab.me>2023-10-02 13:28:40 +0200
commitec247ec4c67afb0424bbb8e6b94749f52d804ed9 (patch)
tree7d2bb00a15368970d6bf59d7ddf523259056788d /flake.nix
parentf211085cd287fd781d33d0a3b1e2297078fe8bbd (diff)
downloadtricot-ec247ec4c67afb0424bbb8e6b94749f52d804ed9.tar.gz
tricot-ec247ec4c67afb0424bbb8e6b94749f52d804ed9.zip
flake.nix: update rustc
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 351bd41..e3aafb1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -5,6 +5,11 @@
inputs.cargo2nix = {
# As of 2022-10-18: two small patches over unstable branch, one for clippy and one to fix feature detection
url = "github:Alexis211/cargo2nix/a7a61179b66054904ef6a195d8da736eaaa06c36";
+
+ # Rust overlay as of 2023-04-25
+ inputs.rust-overlay.url =
+ "github:oxalica/rust-overlay/74f1a64dd28faeeb85ef081f32cad2989850322c";
+
inputs.nixpkgs.follows = "nixpkgs";
};
@@ -15,7 +20,7 @@
overlays = [ cargo2nix.overlays.default ];
};
packageFun = import ./Cargo.nix;
- rustVersion = "1.63.0";
+ rustVersion = "1.68.0";
compile = args: compileMode:
let