aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-01-24 19:28:18 +0100
committerAlex Auvolat <alex@adnab.me>2022-01-24 19:28:18 +0100
commit5e5299a6d0addc6498be12a24451860b9e4c3445 (patch)
treeee09ba8e40ae0e14af3dbe2ec4e576a6f0b4aea0 /Cargo.toml
parentd7511c683d47cdc6eb2d19f4276b359b1c6841f6 (diff)
downloadtricot-5e5299a6d0addc6498be12a24451860b9e4c3445.tar.gz
tricot-5e5299a6d0addc6498be12a24451860b9e4c3445.zip
Add graceful shutdown and memory tracing
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d970836..dd91560 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -35,3 +35,10 @@ accept-encoding-fork = "0.2.0-alpha.3"
async-compression = { version = "0.3", features = ["tokio", "gzip", "zstd", "deflate", "brotli"] }
tokio-util = { version = "0.6", features = ["io"] }
uuid = { version = "0.8.2", features = ["v4"] }
+dhat = { version = "0.3", optional = true }
+
+[profile.release]
+debug = 1
+
+[features]
+dhat-heap = [ "dhat" ]