aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-10-02 12:49:50 +0200
committerAlex Auvolat <alex@adnab.me>2023-10-02 12:49:50 +0200
commit46d517b2f75bfff84b49fe3abc57152dcbc55133 (patch)
tree91e5ae2848b68d769df76977dfccf76b5b416ebf /Cargo.toml
parentf54ab6e51c7280152755f6ebbc56fe5bd9c45198 (diff)
downloadtricot-46d517b2f75bfff84b49fe3abc57152dcbc55133.tar.gz
tricot-46d517b2f75bfff84b49fe3abc57152dcbc55133.zip
cargo upgrades: updage all major versions of deps except opentelemetry
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index afd4c0a..4ab4fb8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,19 +19,19 @@ serde_json = "1.0.89"
tokio = { version = "1.22", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
bytes = "1"
acme-micro = "0.12"
-rustls = { version = "0.20", features = [ "dangerous_configuration" ] }
+rustls = { version = "0.21", features = [ "dangerous_configuration" ] }
rustls-pemfile = "1.0"
chrono = { version = "0.4", features = [ "serde" ] }
hyper = { version = "0.14", features = [ "full" ] }
futures-util = "0.3"
-tokio-rustls = "0.23"
-hyper-rustls = "0.23"
+tokio-rustls = "0.24"
+hyper-rustls = "0.24"
http = "0.2"
structopt = "0.3"
glob = "0.3"
-rcgen = "0.10"
+rcgen = "0.11"
accept-encoding-fork = "0.2.0-alpha.3"
-async-compression = { version = "0.3", features = ["tokio", "gzip", "zstd", "deflate", "brotli"] }
+async-compression = { version = "0.4", features = ["tokio", "gzip", "zstd", "deflate", "brotli"] }
tokio-util = { version = "0.7", features = ["io"] }
uuid = { version = "1.2", features = ["v4"] }
opentelemetry = "0.17"