aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2021-12-06 23:08:22 +0100
committerAlex Auvolat <alex@adnab.me>2021-12-06 23:08:22 +0100
commit2895a8ae2e99f11290800c14f038feda90e1787a (patch)
tree927ce24939b08613f74b9354456308f69286cfb7 /Cargo.toml
downloadtricot-2895a8ae2e99f11290800c14f038feda90e1787a.tar.gz
tricot-2895a8ae2e99f11290800c14f038feda90e1787a.zip
First commit to Tricot, a replacement for Traefik v1
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..1547899
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "tricot"
+version = "0.1.0"
+edition = "2018"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0.28"
+envy = "0.4"
+futures = "0.3.5"
+log = "0.4"
+pretty_env_logger = "0.4"
+regex = "1"
+reqwest = { version = "0.11", features = ["json"] }
+serde = { version = "1.0.107", features = ["derive"] }
+serde_json = "1.0.53"
+tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }