aboutsummaryrefslogtreecommitdiff
path: root/example/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/flake.nix')
-rw-r--r--example/flake.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/example/flake.nix b/example/flake.nix
new file mode 100644
index 0000000..3e48ddb
--- /dev/null
+++ b/example/flake.nix
@@ -0,0 +1,18 @@
+{
+ description = "A very basic flake";
+
+ outputs = { self, nixpkgs }:
+ let
+ pkgs = import nixpkgs { system = "x86_64-linux"; };
+ hello = pkgs.writeScriptBin "hello" ''
+ #!${pkgs.bash}/bin/bash
+ echo "Hello from bash script!"
+ '';
+ in {
+
+ packages.x86_64-linux.hello = hello;
+
+ packages.x86_64-linux.default = self.packages.x86_64-linux.hello;
+
+ };
+}