aboutsummaryrefslogtreecommitdiff
path: root/site/neptune.nix
diff options
context:
space:
mode:
Diffstat (limited to 'site/neptune.nix')
-rw-r--r--site/neptune.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/site/neptune.nix b/site/neptune.nix
index 781e512..f7517c2 100644
--- a/site/neptune.nix
+++ b/site/neptune.nix
@@ -9,4 +9,12 @@
services.nomad.settings.datacenter = "neptune";
networking.firewall.allowedTCPPorts = [ 80 443 ];
+
+ services.cron = {
+ enable = true;
+ systemCronJobs = [
+ "0 2 * * * ${config.system.path}/bin/nix-collect-garbage --delete-older-than 10d"
+ "30 2 * * * ${config.system.path}/bin/docker run --rm -it -v /var/lib/drone/nix:/nix nixpkgs/nix:nixos-21.05 nix-collect-garbage --delete-older-than 10d"
+ ];
+ };
}