aboutsummaryrefslogtreecommitdiff
path: root/cluster/staging/cluster.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cluster/staging/cluster.nix')
-rw-r--r--cluster/staging/cluster.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/cluster/staging/cluster.nix b/cluster/staging/cluster.nix
index 6e0a589..f5cfdc4 100644
--- a/cluster/staging/cluster.nix
+++ b/cluster/staging/cluster.nix
@@ -68,4 +68,24 @@
# For Garage ipv6 communication
networking.firewall.allowedTCPPorts = [ 3991 ];
+
+ ## -----
+
+ ## EXPERIMENTAL ON STAGING: NIX NOMAD DRIVER
+ services.nomad.dropPrivileges = false;
+ services.nomad.extraPackages = [
+ pkgs.nix
+ pkgs.git
+ ];
+ services.nomad.extraSettingsPlugins =
+ let nomad_driver_nix = import ./nomad-driver-nix.nix { inherit pkgs; };
+ in [ nomad_driver_nix ];
+
+ # the nix driver requires flakes to be enabled
+ nix.settings.experimental-features = [ "nix-command" "flakes" ];
+
+ # use our cache as additionnal substituer (we put precompiled packages there,
+ # like we used to do on the docker hub)
+ nix.settings.substituters = [ "https://nix.web.deuxfleurs.fr" ];
+ nix.settings.trusted-public-keys = [ "nix.web.deuxfleurs.fr:eTGL6kvaQn6cDR/F9lDYUIP9nCVR/kkshYfLDJf1yKs=" ];
}