aboutsummaryrefslogtreecommitdiff
path: root/cluster/prod/cluster.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cluster/prod/cluster.nix')
-rw-r--r--cluster/prod/cluster.nix44
1 files changed, 32 insertions, 12 deletions
diff --git a/cluster/prod/cluster.nix b/cluster/prod/cluster.nix
index 1bf4a7b..5446212 100644
--- a/cluster/prod/cluster.nix
+++ b/cluster/prod/cluster.nix
@@ -3,23 +3,43 @@
{
deuxfleurs.cluster_name = "prod";
- # Bootstrap nodes for Wesher overlay network
- services.wesher.join = [
- "192.168.1.31" # concombre
- "192.168.1.32" # courgette
- "192.168.1.33" # celeri
- ];
+ # The IP range to use for the Wireguard overlay of this cluster
+ deuxfleurs.cluster_prefix = "10.83.0.0";
+ deuxfleurs.cluster_prefix_length = 16;
- # The IP range to use for the Wesher overlay of this cluster
- deuxfleurs.wesher_cluster_prefix = "10.83.0.0";
- deuxfleurs.wesher_cluster_prefix_length = 16;
+ deuxfleurs.cluster_nodes = [
+ {
+ hostname = "concombre";
+ site_name = "neptune";
+ publicKey = "VvXT0fPDfWsHxumZqVShpS33dJQAdpJ1E79ZbCBJP34=";
+ IP = "10.83.1.1";
+ lan_endpoint = "192.168.1.31:33799";
+ endpoint = "77.207.15.215:33731";
+ }
+ {
+ hostname = "courgette";
+ site_name = "neptune";
+ publicKey = "goTkBJGmzrGDOAjUcdH9G0JekipqSMoaYQdB6IHnzi0=";
+ IP = "10.83.1.2";
+ lan_endpoint = "192.168.1.32:33799";
+ endpoint = "77.207.15.215:33732";
+ }
+ {
+ hostname = "celeri";
+ site_name = "neptune";
+ publicKey = "oZDAb8LoLW87ktUHyFFec0VaIar97bqq47mGbdVqJ0U=";
+ IP = "10.83.1.3";
+ lan_endpoint = "192.168.1.33:33799";
+ endpoint = "77.207.15.215:33733";
+ }
+ ];
# Bootstrap IPs for Consul cluster,
# these are IPs on the Wesher overlay
services.consul.extraConfig.retry_join = [
- "10.83.101.43" # concombre
- "10.83.66.14" # courgette
- "10.83.12.147" # celeri
+ "10.83.1.1" # concombre
+ "10.83.1.2" # courgette
+ "10.83.1.3" # celeri
];
deuxfleurs.admin_accounts = {