aboutsummaryrefslogtreecommitdiff
path: root/cluster/prod/cluster.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cluster/prod/cluster.nix')
-rw-r--r--cluster/prod/cluster.nix70
1 files changed, 0 insertions, 70 deletions
diff --git a/cluster/prod/cluster.nix b/cluster/prod/cluster.nix
deleted file mode 100644
index d131db7..0000000
--- a/cluster/prod/cluster.nix
+++ /dev/null
@@ -1,70 +0,0 @@
-{ config, pkgs, ... } @ args:
-
-{
- deuxfleurs.cluster_name = "prod";
- deuxfleurs.cluster_nodes = [
- {
- hostname = "concombre";
- site_name = "neptune";
- publicKey = "VvXT0fPDfWsHxumZqVShpS33dJQAdpJ1E79ZbCBJP34=";
- IP = "10.42.1.31";
- endpoint = "82.66.112.151:33731";
- lan_endpoint = "192.168.1.31:33731";
- }
- {
- hostname = "courgette";
- site_name = "neptune";
- publicKey = "goTkBJGmzrGDOAjUcdH9G0JekipqSMoaYQdB6IHnzi0=";
- IP = "10.42.1.32";
- endpoint = "82.66.112.151:33732";
- lan_endpoint = "192.168.1.32:33732";
- }
- {
- hostname = "celeri";
- site_name = "neptune";
- publicKey = "oZDAb8LoLW87ktUHyFFec0VaIar97bqq47mGbdVqJ0U=";
- IP = "10.42.1.33";
- endpoint = "82.66.112.151:33733";
- lan_endpoint = "192.168.1.33:33733";
- }
- ];
- deuxfleurs.admin_nodes = [
- {
- hostname = "hammerhead";
- publicKey = "b5hF+GSTgg3oM6wnjL7jRbfyf1jtsWdVptPPbAh3Qic=";
- IP = "10.42.0.1";
- endpoint = "5.135.179.11:51349";
- }
- {
- hostname = "robinson";
- publicKey = "ETaZFil3mFXlJ0LaJZyWqJVLV2IZUF5PB/8M7WbQSTg=";
- IP = "10.42.0.42";
- endpoint = "77.141.67.109:33742";
- }
- {
- hostname = "shiki";
- publicKey = "QUiUNMk70TEQ75Ut7Uqikr5uGVSXmx8EGNkGM6tANlg=";
- IP = "10.42.0.206";
- endpoint = "37.187.118.206:51820";
- }
- {
- hostname = "lindy";
- publicKey = "wen9GnZy2iLT6RyHfn7ydS/wvdvow1XPmhZxIkrDbks=";
- IP = "10.42.0.66";
- endpoint = "82.66.112.151:33766";
- }
- ];
- deuxfleurs.admin_accounts = {
- lx = [
- # Keys for accessing nodes from outside
- "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIJpaBZdYxHqMxhv2RExAOa7nkKhPBOHupMP3mYaZ73w9 lx@lindy"
- "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDIDdVbA9fEdqSr5UJ77NnoIqDTVp8ca5kHExhZYI4ecBExFJfonJllXMBN9KdC4ukxtY8Ug47PcMOfMaTBZQc+e+KpvDWpkBt15Xpem3RCxmMBES79sLL7LgtAdBXc5mNaCX8EOEVixWKdarjvxRyf6py6the51G5muaiMpoj5fae4ZpRGjhGTPefzc7y7zRWBUUZ8pYHW774BIaK6XT9gn3hyHV+Occjl/UODXvodktk55YtnuPi8adXTYEsHrVVz8AkFhx+cr0U/U8vtQnsTrZG+JmgQLqpXVs0RDw5bE1RefEbMuYNKxutYKUe3L+ZJtDe0M0MqOFI8a4F5TxP5 katchup@konata"
- ];
- };
-
- # For Garage external communication
- networking.firewall.allowedTCPPorts = [ 3901 ];
-
- # Enable netdata monitoring
- services.netdata.enable = true;
-}