aboutsummaryrefslogtreecommitdiff
path: root/nix/wesher.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-04-19 17:41:18 +0200
committerAlex Auvolat <alex@adnab.me>2022-04-19 17:41:18 +0200
commit3d8989b9c918bd4e4b1f8b9a8d294c308fc0b8d9 (patch)
tree6e06494880c55f758190d315528d6e6b20496b9d /nix/wesher.nix
parent65902d47800473a709c0c89ff2edfd3170b3c49c (diff)
downloadnixcfg-infinite-recursion.tar.gz
nixcfg-infinite-recursion.zip
nix infinite recursioninfinite-recursion
Diffstat (limited to 'nix/wesher.nix')
-rw-r--r--nix/wesher.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/nix/wesher.nix b/nix/wesher.nix
new file mode 100644
index 0000000..81be055
--- /dev/null
+++ b/nix/wesher.nix
@@ -0,0 +1,23 @@
+pkgs:
+pkgs.buildGoModule rec {
+ pname = "wesher";
+ version = "0.2.6";
+
+ src = pkgs.fetchFromGitHub {
+ owner = "costela";
+ repo = "wesher";
+ rev = "v${version}";
+ sha256 = "1fnclr556avxay6pvgw5ya3xbxfnf2gv4njq2hr4fd6fcjyslq5h";
+ };
+
+ vendorSha256 = null;
+
+ checkPhase = "true";
+
+ meta = with pkgs.lib; {
+ description = "wireguard overlay mesh network manager";
+ homepage = "https://github.com/costela/wesher";
+ license = licenses.gpl3Plus;
+ platforms = platforms.linux;
+ };
+}