aboutsummaryrefslogtreecommitdiff
path: root/cluster/staging/cluster.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-11-29 15:41:35 +0100
committerAlex Auvolat <alex@adnab.me>2022-11-29 15:41:35 +0100
commitfb4c2ef55aef8191a6ed378d11c4ae1ad9480336 (patch)
treebedd96fa5bfed95e5d87d4b956410b5820ab30f7 /cluster/staging/cluster.nix
parentda07fee575515f2367fc9f1812dac79b4e64c9b9 (diff)
downloadnixcfg-fb4c2ef55aef8191a6ed378d11c4ae1ad9480336.tar.gz
nixcfg-fb4c2ef55aef8191a6ed378d11c4ae1ad9480336.zip
Remove old nomad-driver-nix
Diffstat (limited to 'cluster/staging/cluster.nix')
-rw-r--r--cluster/staging/cluster.nix19
1 files changed, 4 insertions, 15 deletions
diff --git a/cluster/staging/cluster.nix b/cluster/staging/cluster.nix
index 71a8d98..7582992 100644
--- a/cluster/staging/cluster.nix
+++ b/cluster/staging/cluster.nix
@@ -78,25 +78,14 @@
services.nomad.dropPrivileges = false;
# ----- nomad-driver-nix & nomad-driver-nix2 -----
- services.nomad.extraSettingsPlugins =
- let nomad_driver_nix = import ./nomad-driver-nix.nix { inherit pkgs; };
- nomad_driver_nix2 = import ./nomad-driver-nix2.nix { inherit pkgs; };
- in [
- (pkgs.symlinkJoin {
- name = "nomad-drivers";
- paths = [
- nomad_driver_nix
- nomad_driver_nix2
- ];
- })
- ];
- # the nix driver requires flakes to be enabled and some commands to be available
- nix.settings.experimental-features = [ "nix-command" "flakes" ];
+ services.nomad.extraSettingsPlugins = [
+ (import ./nomad-driver-nix2.nix { inherit pkgs; })
+ ];
services.nomad.extraPackages = [
pkgs.nix
pkgs.git
];
- # default config for the exec2 driver
+ # default config for the nix2 driver
services.nomad.settings.plugin = [
{
"nix2-driver" = [