aboutsummaryrefslogtreecommitdiff
path: root/cluster/staging/cluster.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-08-23 23:55:15 +0200
committerAlex Auvolat <alex@adnab.me>2022-08-23 23:55:15 +0200
commitab901fc81d483f24334680a53cacd6b981bb37a7 (patch)
treef104754d49f5c4f09eea34aef3945c9564c1f4df /cluster/staging/cluster.nix
parenta7ac31cdf52b7042cef86f4e04cde96cbc36711f (diff)
downloadnixcfg-ab901fc81d483f24334680a53cacd6b981bb37a7.tar.gz
nixcfg-ab901fc81d483f24334680a53cacd6b981bb37a7.zip
Remove wesher, reconfigure staging without it
Diffstat (limited to 'cluster/staging/cluster.nix')
-rw-r--r--cluster/staging/cluster.nix45
1 files changed, 29 insertions, 16 deletions
diff --git a/cluster/staging/cluster.nix b/cluster/staging/cluster.nix
index 0836dcb..d71b274 100644
--- a/cluster/staging/cluster.nix
+++ b/cluster/staging/cluster.nix
@@ -3,16 +3,36 @@
{
deuxfleurs.cluster_name = "staging";
- # Bootstrap nodes for Wesher overlay network
- services.wesher.join = [
- "192.168.1.21" # cariacou
- "192.168.1.22" # carcajou
- "192.168.1.23" # caribou
- ];
+ # The IP range to use for the Wireguard overlay of this cluster
+ deuxfleurs.cluster_prefix = "10.14.0.0";
+ deuxfleurs.cluster_prefix_length = 16;
- # The IP range to use for the Wesher overlay of this cluster
- deuxfleurs.wesher_cluster_prefix = "10.14.0.0";
- deuxfleurs.wesher_cluster_prefix_length = 16;
+ deuxfleurs.cluster_nodes = [
+ {
+ hostname = "cariacou";
+ site_name = "neptune";
+ publicKey = "qxrtfn2zRVnN52Y5NYumyU3/FcRMnh3kJ2C37JfrczA=";
+ IP = "10.14.179.56";
+ lan_endpoint = "192.168.1.21:33799";
+ endpoint = "192.168.1.21:33799"; ## TODO nat
+ }
+ {
+ hostname = "carcajou";
+ site_name = "neptune";
+ publicKey = "7Nm7pMmyS7Nts1MB+loyD8u84ODxHPTkDu+uqQR6yDk=";
+ IP = "10.14.252.121";
+ lan_endpoint = "192.168.1.22:33799";
+ endpoint = "192.168.1.22:33799"; ## TODO nat
+ }
+ {
+ hostname = "caribou";
+ site_name = "neptune";
+ publicKey = "X1OlfgjZDdJw3yTg0ytGFlJZXzqT0yHJmYP15R9IpD8=";
+ IP = "10.14.181.82";
+ lan_endpoint = "192.168.1.23:33799";
+ endpoint = "192.168.1.23:33799"; ## TODO nat
+ }
+ ];
# Bootstrap IPs for Consul cluster,
# these are IPs on the Wesher overlay
@@ -22,13 +42,6 @@
"10.14.252.121" # carcajou
];
- # Add wesher hosts to /etc/hosts, needed for elasticsearch
- networking.extraHosts = ''
-10.14.181.82 caribou
-10.14.179.56 cariacou
-10.14.242.121 carcajou
- '';
-
deuxfleurs.admin_accounts = {
lx = [
# Keys for accessing nodes from outside