aboutsummaryrefslogtreecommitdiff
path: root/cluster/prod/app/cryptpad/build/shell.nix
diff options
context:
space:
mode:
authorKokaKiwi <kokakiwi+git@kokakiwi.net>2024-04-18 18:56:19 +0200
committerKokaKiwi <kokakiwi+git@kokakiwi.net>2024-04-18 18:56:19 +0200
commit9111997f845cb61bcbe5b5f49672ba26814d19c9 (patch)
tree701c4dc457658904420bddff944cac6f906aa991 /cluster/prod/app/cryptpad/build/shell.nix
parentd41e10bd25e54ae46b4c35f677abb593fde4c60d (diff)
downloadnixcfg-9111997f845cb61bcbe5b5f49672ba26814d19c9.tar.gz
nixcfg-9111997f845cb61bcbe5b5f49672ba26814d19c9.zip
cluster/prod(app): Add new CryptPad build files
Diffstat (limited to 'cluster/prod/app/cryptpad/build/shell.nix')
-rw-r--r--cluster/prod/app/cryptpad/build/shell.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/cluster/prod/app/cryptpad/build/shell.nix b/cluster/prod/app/cryptpad/build/shell.nix
deleted file mode 100644
index bf701fe..0000000
--- a/cluster/prod/app/cryptpad/build/shell.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-let
- common = import ./common.nix;
- pkgs = import common.pkgsSrc {};
-
- bower2nixRepo = (import common.bower2nixSrc {
- inherit pkgs;
- });
- bower2nix = bower2nixRepo // {
- package = bower2nixRepo.package.override {
- postInstall = "tsc";
- };
- };
-in
- pkgs.mkShell {
- nativeBuildInputs = [
- bower2nix.package
- pkgs.nodePackages.node2nix
- ];
-
- shellHook = ''
-function update_lock {
- set -exuo pipefail
- mkdir -p nix.lock
- ${pkgs.wget}/bin/wget https://raw.githubusercontent.com/xwiki-labs/cryptpad/${common.cryptpadCommit}/package.json -O nix.lock/package.json
- ${pkgs.wget}/bin/wget https://raw.githubusercontent.com/xwiki-labs/cryptpad/${common.cryptpadCommit}/package-lock.json -O nix.lock/package-lock.json
- ${pkgs.wget}/bin/wget https://raw.githubusercontent.com/xwiki-labs/cryptpad/${common.cryptpadCommit}/bower.json -O nix.lock/bower.json
- ${bower2nix.package}/bin/bower2nix nix.lock/bower.json nix.lock/bower.nix
- ${pkgs.nodePackages.node2nix}/bin/node2nix --input nix.lock/package.json --lock nix.lock/package-lock.json --composition nix.lock/npm.nix --node-env nix.lock/node-env.nix --output nix.lock/node-packages.nix
-}
- '';
- }