aboutsummaryrefslogtreecommitdiff
path: root/app/cryptpad/build/default.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-05-06 17:55:23 +0200
committerQuentin Dufour <quentin@deuxfleurs.fr>2022-05-06 17:55:23 +0200
commit1a6371d8d57f081132b253054f639376c4db6afa (patch)
tree26acf676c572ca0e45443866d32ac3b137369af8 /app/cryptpad/build/default.nix
parent071e87a2025edfa8694fd3ae05be894d2be434ee (diff)
downloadnixcfg-1a6371d8d57f081132b253054f639376c4db6afa.tar.gz
nixcfg-1a6371d8d57f081132b253054f639376c4db6afa.zip
Mostly working Cryptpad
Diffstat (limited to 'app/cryptpad/build/default.nix')
-rw-r--r--app/cryptpad/build/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/app/cryptpad/build/default.nix b/app/cryptpad/build/default.nix
index 2cf0ae3..65ffad8 100644
--- a/app/cryptpad/build/default.nix
+++ b/app/cryptpad/build/default.nix
@@ -37,20 +37,23 @@ in
# clear executable files inside the node_modules folder to reduce dependencies
# and attack surface
find node_modules -type f ! -path 'node_modules/gar/*' -executable -print | tee >(xargs -n 20 rm)
+
+ # Remove only office that IS BIG
+ rm -rf www/onlyoffice
'';
installPhase = ''
mkdir -p $out/{bin,opt}
# copy the source code
- cp -r customize.dist lib server.js www $out/opt/
+ cp -r .bowerrc bower.json package.json package-lock.json customize.dist lib server.js www $out/opt/
# mount node_modules
cp -r node_modules $out/opt/node_modules
# mount bower, based on the .bowerrc file at the git repo root
- cp -r ${bower} $out/opt/www/bower_components
+ cp -r ${bower}/bower_components $out/opt/www/
# cryptpad is bugged with absolute path, this is a workaround to use absolute path as relative path
ln -s / $out/opt/root