aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2020-12-02 13:30:47 +0100
committerAlex Auvolat <alex@adnab.me>2020-12-02 13:30:47 +0100
commitd4de2ffc40fe9d003f12139053ca070eda0b7221 (patch)
treee95476f0b7a6d1c75cc462b3ea7eee74c4faf09f /Cargo.toml
downloadnetapp-d4de2ffc40fe9d003f12139053ca070eda0b7221.tar.gz
netapp-d4de2ffc40fe9d003f12139053ca070eda0b7221.zip
First commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..9c0eadb
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "netapp"
+version = "0.1.0"
+authors = ["Alex Auvolat <alex.auvolat@inria.fr>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+async-std = { version = "1.5.0", features=["unstable","attributes"] }
+tokio = { version = "0.2", features = ["full"] }
+kuska-handshake = { path = "../../handshake", features = ["default", "tokio_compat"] }
+hex = "0.4.2"
+log = "0.4.8"
+pretty_env_logger = "0.4"
+sodiumoxide = { git = "https://github.com/Dhole/sodiumoxidez", branch = "extra" }
+env_logger = "0.7.1"
+base64 = "0.12.1"
+rmp-serde = "0.14.3"
+serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
+arc-swap = "1.0"
+structopt = { version = "0.3", default-features = false }
+async-trait = "0.1.7"
+err-derive = "0.2.3"
+bytes = "0.6.0"
+lru = "0.6"
+rand = "0.5.5"