aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..a253897
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,12 @@
+{ pkgs ? import <nixpkgs> {} }:
+ pkgs.mkShell {
+ nativeBuildInputs = [
+ pkgs.python310
+ pkgs.python310Packages.pyyaml
+ pkgs.python310Packages.requests
+
+ # to test the pip setup
+ pkgs.python310Packages.pip
+ pkgs.python310Packages.setuptools
+ ];
+}