aboutsummaryrefslogtreecommitdiff
path: root/app/shell.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-01-27 13:31:25 +0100
committerQuentin Dufour <quentin@deuxfleurs.fr>2022-01-27 13:31:25 +0100
commit00d7106a18b8ab27910b04bfabb0bb5bb0d4fd00 (patch)
tree949da422d223236ff355e055535c3e63bf4b3e72 /app/shell.nix
parent831ddd30558d9015f9219ae28384a414d7b73bf6 (diff)
downloadinfrastructure-00d7106a18b8ab27910b04bfabb0bb5bb0d4fd00.tar.gz
infrastructure-00d7106a18b8ab27910b04bfabb0bb5bb0d4fd00.zip
Redeploy plume
Diffstat (limited to 'app/shell.nix')
-rw-r--r--app/shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/app/shell.nix b/app/shell.nix
new file mode 100644
index 0000000..c9b8053
--- /dev/null
+++ b/app/shell.nix
@@ -0,0 +1,15 @@
+{
+ pkgs ? import <nixpkgs> {}
+}:
+
+with pkgs; mkShell {
+ nativeBuildInputs = [
+ nomad
+ docker-compose
+ python39Packages.pip
+ python39Packages.ldap
+ python39Packages.consul
+ python39Packages.passlib
+ ];
+}
+