aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-07-19 15:53:39 +0200
committerQuentin Dufour <quentin@deuxfleurs.fr>2022-07-19 15:53:39 +0200
commit158eda06de31a52f15712fa0e5695054d15dfe3a (patch)
treefb86ecd31a1195111581f77ba49665002d442dc1 /default.nix
parenta84ac778adf57d6446eef6577e617a80d4c6bb8e (diff)
downloadguichet-158eda06de31a52f15712fa0e5695054d15dfe3a.tar.gz
guichet-158eda06de31a52f15712fa0e5695054d15dfe3a.zip
Format + documentation
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix22
1 files changed, 9 insertions, 13 deletions
diff --git a/default.nix b/default.nix
index 24b759c..cd17475 100644
--- a/default.nix
+++ b/default.nix
@@ -11,7 +11,8 @@ let
})
];
};
- bin = pkgs.gomod.buildGoApplication {
+in rec {
+ bin = pkgs.gomod.buildGoApplication {
pname = "guichet-bin";
version = "0.1.0";
src = ./.;
@@ -26,23 +27,18 @@ let
platforms = platforms.linux;
};
};
-in
- pkgs.stdenv.mkDerivation {
+ pkg = pkgs.stdenv.mkDerivation {
pname = "guichet";
version = "0.1.0";
src = ./.;
installPhase = ''
mkdir -p $out/
-
- cat > guichet <<EOF
- #!${pkgs.bash}/bin/bash
- cd $out
- ${bin}/bin/guichet \$@
- EOF
- chmod +x guichet
-
- cp guichet $out/guichet
+ cp ${bin}/bin/guichet $out/guichet
cp -r templates static $out/
'';
- }
+ };
+ /*docker = pkgs.xxx {
+
+ };*/
+}