aboutsummaryrefslogtreecommitdiff
path: root/src/web/Cargo.toml
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2023-05-07 18:12:01 +0200
committerAlex <alex@adnab.me>2023-05-09 08:46:15 +0000
commitd2deee0b8bc22de5e8f1115f65a8a979b1beba18 (patch)
treecf10ec13bb72f9ad0aa806030f92c02549a88e47 /src/web/Cargo.toml
parent8499cd5c21f336111160b437d11d16fede67a916 (diff)
downloadgarage-d2deee0b8bc22de5e8f1115f65a8a979b1beba18.tar.gz
garage-d2deee0b8bc22de5e8f1115f65a8a979b1beba18.zip
Declare garage crates using workspace.dependencies
This will allow to really disable "sled" feature without declaring `default-features = false` in every Cargo.toml where garage_db and garage_model is used. See https://doc.rust-lang.org/cargo/reference/workspaces.html#the-dependencies-table
Diffstat (limited to 'src/web/Cargo.toml')
-rw-r--r--src/web/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/web/Cargo.toml b/src/web/Cargo.toml
index d0a23af4..423d3829 100644
--- a/src/web/Cargo.toml
+++ b/src/web/Cargo.toml
@@ -14,10 +14,10 @@ path = "lib.rs"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-garage_api = { version = "0.8.2", path = "../api" }
-garage_model = { version = "0.8.2", path = "../model" }
-garage_util = { version = "0.8.2", path = "../util" }
-garage_table = { version = "0.8.2", path = "../table" }
+garage_api.workspace = true
+garage_model.workspace = true
+garage_util.workspace = true
+garage_table.workspace = true
err-derive = "0.3"
tracing = "0.1"