aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/Cargo.toml
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-09-03 18:37:24 +0200
committerJakub Jirutka <jakub@jirutka.cz>2022-09-03 18:44:34 +0200
commita6e40b75eabf0d6a863a91ae17f7d0ae20582d9e (patch)
tree71734578b3085c2d6d9ff4121612261b79aee22c /src/rpc/Cargo.toml
parent532eca7ff94e4710283fb38951a349a83654de59 (diff)
downloadgarage-a6e40b75eabf0d6a863a91ae17f7d0ae20582d9e.tar.gz
garage-a6e40b75eabf0d6a863a91ae17f7d0ae20582d9e.zip
Add feature "system-libs" to enable linking against system libraries
If this feature is enabled, libsodium-sys and zstd-sys will link dynamically against system-provided libraries instead of building and linking statically the bundled (possibly outdated and vulnerable) copies of them. This feature is intended mainly for linux package maintainers.
Diffstat (limited to 'src/rpc/Cargo.toml')
-rw-r--r--src/rpc/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/rpc/Cargo.toml b/src/rpc/Cargo.toml
index 80a1975c..309e3fc2 100644
--- a/src/rpc/Cargo.toml
+++ b/src/rpc/Cargo.toml
@@ -54,3 +54,4 @@ hyper = { version = "0.14", features = ["client", "http1", "runtime", "tcp"] }
[features]
kubernetes-discovery = [ "kube", "k8s-openapi", "openssl", "schemars" ]
+system-libs = [ "sodiumoxide/use-pkg-config" ]