aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2021-03-18 21:59:17 +0100
committerAlex Auvolat <alex@adnab.me>2021-03-18 21:59:17 +0100
commit4c26a0b9c17fee84a64cd79a6b31968fd48effe6 (patch)
tree602788de9fea5550c33757180d8cb6fa7c7b85a5 /src/rpc/Cargo.toml
parenta1014224d32151dbba7083eb03d8e500beb67f4c (diff)
downloadgarage-4c26a0b9c17fee84a64cd79a6b31968fd48effe6.tar.gz
garage-4c26a0b9c17fee84a64cd79a6b31968fd48effe6.zip
Update Cargo.toml files with AGPL license infov0.2.0
Diffstat (limited to 'src/rpc/Cargo.toml')
-rw-r--r--src/rpc/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/rpc/Cargo.toml b/src/rpc/Cargo.toml
index 4ae53fc8..41d4e0eb 100644
--- a/src/rpc/Cargo.toml
+++ b/src/rpc/Cargo.toml
@@ -3,7 +3,7 @@ name = "garage_rpc"
version = "0.2.0"
authors = ["Alex Auvolat <alex@adnab.me>"]
edition = "2018"
-license = "GPL-3.0"
+license = "AGPL-3.0"
description = "Cluster membership management and RPC protocol for the Garage object store"
repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
@@ -15,10 +15,10 @@ path = "lib.rs"
[dependencies]
garage_util = { version = "0.2.0", path = "../util" }
-bytes = "1.0"
-hex = "0.4"
arc-swap = "1.0"
+bytes = "1.0"
gethostname = "0.2"
+hex = "0.4"
log = "0.4"
rmp-serde = "0.15"
@@ -32,9 +32,9 @@ tokio-stream = { version = "0.1", features = ["net"] }
http = "0.2"
hyper = { version = "0.14", features = ["full"] }
+hyper-rustls = { version = "0.22", default-features = false }
rustls = "0.19"
tokio-rustls = "0.22"
-hyper-rustls = { version = "0.22", default-features = false }
webpki = "0.21"