aboutsummaryrefslogtreecommitdiff
path: root/src/model/Cargo.toml
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2022-11-21 13:55:50 +0000
committerAlex <alex@adnab.me>2022-11-21 13:55:50 +0000
commit1e40c93fd033ab5d373425dffe4a855f2ba14304 (patch)
tree1e2a7779bb9303232c5aa14bc1812986daf5fced /src/model/Cargo.toml
parent7fafd14a25a800fcc9fde1434319b35d536c675f (diff)
parent0cfb56d33eea76a20d51af3d140cd1855184ae5c (diff)
downloadgarage-0.8.0.tar.gz
garage-0.8.0.zip
Merge pull request 'Changes for v0.8.0' (#428) from v0.8.0-tmp into mainv0.8.0
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/428
Diffstat (limited to 'src/model/Cargo.toml')
-rw-r--r--src/model/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/model/Cargo.toml b/src/model/Cargo.toml
index 2c2e2bfe..08baf81f 100644
--- a/src/model/Cargo.toml
+++ b/src/model/Cargo.toml
@@ -14,7 +14,7 @@ path = "lib.rs"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-garage_db = { version = "0.8.0", path = "../db" }
+garage_db = { version = "0.8.0", default-features = false, path = "../db" }
garage_rpc = { version = "0.8.0", path = "../rpc" }
garage_table = { version = "0.8.0", path = "../table" }
garage_block = { version = "0.8.0", path = "../block" }
@@ -42,6 +42,7 @@ opentelemetry = "0.17"
netapp = "0.5"
[features]
+default = [ "sled" ]
k2v = [ "garage_util/k2v" ]
lmdb = [ "garage_db/lmdb" ]
sled = [ "garage_db/sled" ]