aboutsummaryrefslogtreecommitdiff
path: root/src/api/s3/Cargo.toml
diff options
context:
space:
mode:
authorAlex <lx@deuxfleurs.fr>2025-02-01 17:48:25 +0000
committerAlex <lx@deuxfleurs.fr>2025-02-01 17:48:25 +0000
commitd601f311865b8159a7bf1801dd8f43021d0b443b (patch)
tree07e4268d09a6bead4c4e5a2a4f122471a7a5d23b /src/api/s3/Cargo.toml
parent9330fd79d3466051394f6d419a247d46da8f5151 (diff)
parente4de7bdfd5e6acc05309f59d7f77755f0807e8e4 (diff)
downloadgarage-d601f311865b8159a7bf1801dd8f43021d0b443b.tar.gz
garage-d601f311865b8159a7bf1801dd8f43021d0b443b.zip
Merge pull request 'split garage_api in garage_api_{common,s3,k2v,admin}' (#947) from split-garage-api into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/947
Diffstat (limited to 'src/api/s3/Cargo.toml')
-rw-r--r--src/api/s3/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/src/api/s3/Cargo.toml b/src/api/s3/Cargo.toml
new file mode 100644
index 00000000..a1751c9f
--- /dev/null
+++ b/src/api/s3/Cargo.toml
@@ -0,0 +1,61 @@
+[package]
+name = "garage_api_s3"
+version = "1.0.1"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+edition = "2018"
+license = "AGPL-3.0"
+description = "S3 API server crate for the Garage object store"
+repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
+readme = "../../README.md"
+
+[lib]
+path = "lib.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+garage_model.workspace = true
+garage_table.workspace = true
+garage_block.workspace = true
+garage_net.workspace = true
+garage_util.workspace = true
+garage_rpc.workspace = true
+garage_api_common.workspace = true
+
+aes-gcm.workspace = true
+async-compression.workspace = true
+async-trait.workspace = true
+base64.workspace = true
+bytes.workspace = true
+chrono.workspace = true
+crc32fast.workspace = true
+crc32c.workspace = true
+err-derive.workspace = true
+hex.workspace = true
+tracing.workspace = true
+md-5.workspace = true
+pin-project.workspace = true
+sha1.workspace = true
+sha2.workspace = true
+
+futures.workspace = true
+tokio.workspace = true
+tokio-stream.workspace = true
+tokio-util.workspace = true
+
+form_urlencoded.workspace = true
+http.workspace = true
+httpdate.workspace = true
+http-range.workspace = true
+http-body-util.workspace = true
+hyper = { workspace = true, default-features = false, features = ["server", "http1"] }
+multer.workspace = true
+percent-encoding.workspace = true
+roxmltree.workspace = true
+url.workspace = true
+
+serde.workspace = true
+serde_json.workspace = true
+quick-xml.workspace = true
+
+opentelemetry.workspace = true