aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2024-02-09 12:47:03 +0100
committerAlex Auvolat <alex@adnab.me>2024-02-09 12:49:17 +0100
commitf7ae966ed34d3ca8fb20afd2f20874dd42df7f7e (patch)
tree08336bb7610c35b7707d3c87fd3f4eac7e2b21f7 /shell.nix
parent561fad0b44f78372357c1c76e3708a062d703b33 (diff)
downloadgarage-f7ae966ed34d3ca8fb20afd2f20874dd42df7f7e.tar.gz
garage-f7ae966ed34d3ca8fb20afd2f20874dd42df7f7e.zip
[nix-improvements] special case for Docker's "386" architecturenix-improvements
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 12daa502..0fa02b66 100644
--- a/shell.nix
+++ b/shell.nix
@@ -45,8 +45,8 @@ in
function to_docker {
executor \
--force \
- --customPlatform="''${DOCKER_PLATFORM}" \
- --destination "''${CONTAINER_NAME}:''${CONTAINER_TAG}" \
+ --customPlatform="$(echo "''${DOCKER_PLATFORM}" | sed 's/i386/386/')" \
+ --destination "$(echo "''${CONTAINER_NAME}" | sed 's/i386/386/'):''${CONTAINER_TAG}" \
--context dir://`pwd` \
--verbosity=debug
}