aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2024-02-09 11:15:52 +0100
committerAlex Auvolat <alex@adnab.me>2024-02-09 11:15:52 +0100
commitd35d4599de13d2bad95523547bb368f1c754a014 (patch)
tree7a2a2b63d293c8730783a5d384edefaa441a4d0d /shell.nix
parent9900368380513d8b898d6ac4116e09525341c11b (diff)
downloadgarage-d35d4599de13d2bad95523547bb368f1c754a014.tar.gz
garage-d35d4599de13d2bad95523547bb368f1c754a014.zip
[nix-improvements] use kaniko and manifest-tools from nixpkgs, simplify
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix26
1 files changed, 2 insertions, 24 deletions
diff --git a/shell.nix b/shell.nix
index bd150743..193ed941 100644
--- a/shell.nix
+++ b/shell.nix
@@ -6,8 +6,6 @@ let
pkgs = import pkgsSrc {
inherit system;
};
- kaniko = (import ./nix/kaniko.nix) pkgs;
- manifest-tool = (import ./nix/manifest-tool.nix) pkgs;
winscp = (import ./nix/winscp.nix) pkgs;
in
{
@@ -18,10 +16,10 @@ in
# The shell used for all CI jobs (along with devShell)
ci = pkgs.mkShell {
nativeBuildInputs = with pkgs; [
- kaniko
- manifest-tool
winscp
+ kaniko
+ manifest-tool
awscli2
file
s3cmd
@@ -123,15 +121,6 @@ in
# A shell for refreshing caches
cache = pkgs.mkShell {
shellHook = ''
- function refresh_toolchain {
- pass show deuxfleurs/nix_priv_key > /tmp/nix-signing-key.sec
- nix copy -j8 \
- --to 's3://nix?endpoint=garage.deuxfleurs.fr&region=garage&secret-key=/tmp/nix-signing-key.sec' \
- $(nix-store -qR \
- $(nix-build -j8 --no-build-output --no-out-link nix/toolchain.nix))
- rm /tmp/nix-signing-key.sec
- }
-
function refresh_cache {
pass show deuxfleurs/nix_priv_key > /tmp/nix-signing-key.sec
for attr in clippy.amd64 test.amd64 pkgs.{amd64,i386,arm,arm64}.release; do
@@ -143,17 +132,6 @@ in
done
rm /tmp/nix-signing-key.sec
}
-
- function refresh_flake_cache {
- pass show deuxfleurs/nix_priv_key > /tmp/nix-signing-key.sec
- for attr in packages.x86_64-linux.default devShells.x86_64-linux.default; do
- echo "Updating cache for ''${attr}"
- nix copy -j8 \
- --to 's3://nix?endpoint=garage.deuxfleurs.fr&region=garage&secret-key=/tmp/nix-signing-key.sec' \
- ".#''${attr}"
- done
- rm /tmp/nix-signing-key.sec
- }
'';
};
}